MS Excel – JEŻELI.BŁĄD()

Trudność: 🟢 (łatwe)


Na załączonym obrazku widzimy zestawienie osób wraz z wypracowanymi pieniędzmi oraz naliczonymi łącznymi podatkami. W komórce G3 użyto formuły =F3*60% (60% to szacunkowa wartość wszystkich 97. podatków, które każdy Polak płacił w 2022 roku).

Zauważmy jednak, że niektóre formuły (np. G5, G7) zwracają (wyliczają) błąd #ARG!, a to uniemożliwia tworzenie formuł bazujących na tych wynikach (np. SUMA(G3:G13)) zwróci błąd). Jak to naprawić?

  • podświetlamy pierwszą formułę (G3)
  • naciskamy F2 (więcej o edycji formuł)
  • znajdujemy tam formułę =F3*60%
  • na jej początku (ale za znakiem =) dopisujemy JEŻELI.BŁĄD(
  • na końcu dopisujemy np. ;”nie da się wyliczyć” (średnik i napis w cudzysłowie)
  • formuła w całości wygląda tak: =JEŻELI.BŁĄD(F3*60%;”nie da się wyliczyć“)
  • kopiujemy ją w dół

Teraz mała korekta. Zamiast napisu nie da się wyliczyć chcemy pusta komórkę. Zatem wykasowujemy napis nie da się wyliczyć ale zostawiamy cudzysłowy. Uzyskujemy formułę =JEŻELI.BŁĄD(F3*60%;””). Zapis “” oznacza pustą komórkę (pusta wartość tekstową).

Zobacz też przykłady i opisy innych funkcji dostępnych w MS Excel.