MS Excel – typy zawartości

By sprawnie poruszać się w MS Excel ważne jest rozróżnianie typów treści wpisywanych do komórek. Okazuje się, że wszystko co wpisujemy do komórek MS Excel musi zostać przypisane do jednego z typów. Jeśli zostanie przypisane nieprawidłowo… niektóre formuły mogą nie działać prawidłowo.

Oto kilka przykładów:

typ TEKST:

  • Ala ma kota

typ LICZBA:

  • 566,789
  • 0,00002

typ LOGICZNE:

  • PRAWDA
  • FAŁSZ

Podpowiedzi MS Excel

Typ TEKST wyrównywany jest do lewej strony komorki.

Typ LICZBA wyrównywany jest do prawej strony komórki.

Typ LOGICZNE wyrównywany jest do środka komórki, a czcionka zmieniona na wersaliki.

Przypadki szczególne

Ponieważ Excel (niestety) baaardzo chce pomagać, należy więc rozpatrzyć kilka typowych przypadków szczególnych:

  • Jeśli do komórki wpiszemy 12.5 (z kropką, a nie przecinkiem), to Excel postanowi w ramach pomocy zmienić taki zapis na datę 12 maja. I co gorsze zmienił też format tej komórki na datę. Czyli cokolwiek teraz wpiszesz, będzie zmieniane na datę.
    Dlaczego? Bo wpisaliśmy kropkę zamiast przecinka!
    WNIOSKI: uważaj na przecinki i kropki! To nie jest to samo.
  • Jeśli do komórki wpiszemy prawda, to Excel zmieni to na PRAWDA i wyśrodkuje.
    Dlaczego? Bo rozpoznał wartość logiczną. Są takie dwie: PRAWDA i FAŁSZ.
    WNIOSKI: jeśli chcesz wpisać prawda (jako tekst), to musisz rozpocząć od apostrofu ‘. Czyli piszesz ‘prawda. Apostrof na początku komórki wymusza utworzenie wartości tekstowej. Jeśli napiszesz =2*3, Excel wyliczy wynik (6), ale jeśli wpiszesz ‘=2*3, to Excel pozostawi w komórce =2*3.
  • Jeśli do komórki wpiszemy 20 zł, to Excel wykona kilka operacji (w mgnieniu oka). Wykasuje . Wpisze do komórki 20. Zmieni format komórki na walutowy. Sprawdź. Wpisz 20 zł. Popatrz na pasek formuły (znajdziesz tam 20).

A co z formułami i funkcjami?

Nie ma typu FORMUŁA lub FUNKCJA. Ale gdy do komórki wpiszemy formułę (formuły zaczynają się od znaku =), ta zostanie wyliczona, a wyniku tego powstanie jakaś zawartość typu tekstowego, liczbowego lub logicznego.

  • =2*5 wynik typu LICZBA
  • =A2+8 wynik typu LICZBA
  • =SUMA(A1:B5) wynik typu LICZBA
  • =FRAGMENT.TEKSTU(A1;2;1) wynik typu TEKST
  • =CZY.LICZBA(A1) wynik typu LOGICZNE

PS. Należy odróżniać formułę od funkcji. Formuła to zapis w komórce rozpoczynający się od =. Funkcja to np. SUMA(), LICZ.JEŻELI(), ŚREDNIA(). Oto przykład formuły wykorzystującej dwie funkcje:
=SUMA(A1:B10)*LICZ.JEŻELI(A1:B10;2)+15